Checklist for installing NCompPOS
1. Any Windows XP PC or higher
2. You need Mysql server 5.0 or higher already installed and working. For instructions to install MySQL click here.

To download NCompPOS v1.1.5.17 press on the Download button. For Version history click here

To download NCompPOS v2.0.2 click here. (Not all features from NCompPOS v1 is present in NCompPOS v2. In time all features will be present.)

Click here for support